Capitec is experiencing intermittent issues across multiple platforms
Incident Report for BankTech
Resolved
Update from Capitec: Thank you to our clients for your patience. The issue has been resolved. All channels are operational.
Posted Aug 06, 2022 - 11:55 CAT
Update
Update from Capitec: We are still experiencing technical issues. We are absolutely committed to resolving the issue and have experts who are on it. We sincerely apologise for the inconvenience caused to affected clients.

Only card payments and ATM’s online are working. Digital banking channels and their branches are still down.

No timeline for resolution provided.
Posted Aug 05, 2022 - 12:20 CAT
Update
Capitec is still experiencing an infrastructure problem in the central servers that support their banking channels.
Feedback received: We are committed to resolving this as soon as possible and have a team of technology experts correcting the problem.
Posted Aug 05, 2022 - 08:28 CAT
Investigating
We are aware that Capitec Bank Account Verifications are not operational. Turnaround time unknown.
Posted Aug 04, 2022 - 13:30 CAT
This incident affected: Data Services (Bank Account Verification).