Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 19, 2026 - 18:00 CAT
Scheduled
This notification serves to confirm that Absa Bank Ltd will be conducting a planned maintenance change on our mainframe application on 19-20 August 2026.
Change Window: Start Time: Wednesday, 19 August 2026 at 18:00 PM End Time: Thursday 20 August 2026 10:00 AM
Downtime: Start Time: Thursday, 20 August 2026 at 01:00 AM End Time: Thursday 20 August 2026 02:00 AM
Impact services: RTC Payment (Real-time clearance) Cashsend Notify Me for Business (NMB) Payshap
Downtime: There will be downtime and therefore causing processing delays during the change window. The change will be monitored with all support groups on high alert.
The Absa Team
Posted Aug 19, 2026 - 16:19 CAT
This scheduled maintenance affected: Bank Integrations (ABSA Host - Submission Service, ABSA Host - Result Service).