BankTech: Microsoft Azure Major Outage 2025-10-29

Incident Report for BankTech

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:06 CAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 21:55 CAT

Investigating

To our valued clients,

Please be advised that Microsoft Azure services are currently experiencing a major outage.

Due to the use of Microsoft Azure services within the BankTech Platform, this will affect the availability of our services.

Our Infrastructure Support Engineering team is currently working with Microsoft to resolve the issue.

Note that the BankTech platform has a three-tier failover process (Ireland/Netherlands/Japan) to protect your data while the services are being restored.

We appreciate your patience during this time.

Kind regards
BankTech Incident Response Team
Posted Oct 29, 2025 - 19:26 CAT
This incident affected: BankTech Platform (BankTech API, BankTech Web App).