Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 13, 2025 - 20:00 CAT
Scheduled
Dear Valued Client
This notification serves to confirm that Absa Bank Ltd will be conducting a planned maintenance upgrade on our mainframe application on 13-14 September 2025.
Change Window: Start: Saturday 13 September 2025 at 20:00 PM End: Sunday 14 September 2025 at 09:00 AM
Impact services: This will impact below services during the change window. RTC Payment (Real-time clearance) Notify Me for Business (NMB) Host Files AVS (Batch)
Client impact: There will be intermittent downtime during the change window and a delay with the delivery of bank statements and response files on Sunday morning. The estimated time for the backlog of files to be cleared is around 11:00 AM.
Posted Sep 11, 2025 - 09:44 CAT
This scheduled maintenance affects: Bank Integrations (ABSA Host - Submission Service, ABSA Host - Result Service).